< návrat zpět

MS Excel


Téma: souhrn docházka noční směna rss

Zaslal/a 24.3.2022 19:04

LugrAhoj všem,

prosím o radu, v docházce používám vzorec

pro příchod:
{=KDYŽ(I4="";"";MIN(KDYŽ($C$4:$C$37=I4;$D$4:$D$37)))}

a pro odchod:
{=KDYŽ(I4="";"";MAX(KDYŽ($C$4:$C$37=I4;$E$4:$E$37)))}

Problém nastává u noční směny. V příloze je to vidět.

Děkuji za pomoc

Příloha: xlsx52348_dochazka-nocni-smena.xlsx (14kB, staženo 28x)
Zaslat odpověď >

Strana:  1 2 3   další »
#052361
avatar
Ahoj, myslím si, že u příchodu potřebuješ zjistit první příchod a u odchodu poslední odchod, zatímco zjišťuješ minimální resp. maximální časový údaj. Momentálně nevím, jak to nějak elegantně zadat. Ale někdo určitě poradí přesně. Ahoj Q.citovat
#052362
Lugr

anonym napsal/a:

Ahoj, myslím si, že u příchodu potřebuješ zjistit první příchod a u odchodu poslední odchod, zatímco zjišťuješ minimální resp. maximální časový údaj. Momentálně nevím, jak to nějak elegantně zadat. Ale někdo určitě poradí přesně. Ahoj Q.


Přesně jak říkáš. Funkce MAX a MIN při denní směně funguje dobře, ale u noční je k ničemu.citovat
#052363
Fantasyk
Takhle to může být?
Příloha: xlsx52363_dochazka-nocni-smena-pokus.xlsx (13kB, staženo 25x)
citovat
#052364
Lugr

Fantasyk napsal/a:

Takhle to může být?Příloha: 52363_dochazka-nocni-smena-pokus.xlsx (13kB, staženo 1x)


Děkuju za návrh. Toto ale funguje jen za předpokladu, že bude příchod na prvním řádku a odchod na posledním.citovat
#052365
Fantasyk

Lugr napsal/a:

Fantasyk napsal/a:Takhle to může být?Příloha: 52363_dochazka-nocni-smena-pokus.xlsx (13kB, staženo 1x)

Děkuju za návrh. Toto ale funguje jen za předpokladu, že bude příchod na prvním řádku a odchod na posledním.


tak to máš, ale všude.citovat
#052366
Lugr
Mám, je to jen zkušební soubor, ale kolegové to tam mastí jak jim to přijde pod ruku.citovat
#052367
Fantasyk

Lugr napsal/a:

Mám, je to jen zkušební soubor, ale kolegové to tam mastí jak jim to přijde pod ruku.


Datum u toho máš taky ?citovat
#052368
Lugr
Datum je společný pro celý protokol v buňce C4. A jména také nejdou za sebou ale jsou na přeskáčku.citovat
#052369
Fantasyk

Lugr napsal/a:

Datum je společný pro celý protokol v buňce C4. A jména také nejdou za sebou ale jsou na přeskáčku.


Jako udělal bych to celé trochu jinak. přes makro a userform, aby to lidi nezadávali ručně, ale pomocí výběru ze seznamu, aby se eliminovala trochu lidská chybovost.

Pokud mi pošleš kousek originálu s jinými jmény atd.. tak ti to udělám přes userform, a data se budou urovnávam a nebude v tom takový "maglajz" :-)citovat
#052370
Lugr
Nechtěl jsem úplné přidělávat práci. 7
Příloha: xlsx52370_protokol-2.xlsx (49kB, staženo 26x)
citovat

Strana:  1 2 3   další »

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

Zaokrouhlování

JoKe • 14.6. 15:19

Zaokrouhlování

Mirek-Kraus • 14.6. 13:52

excell uprava riadku vzorca

veny • 14.6. 7:52

excell uprava riadku vzorca

orangezradca • 13.6. 20:37

pomala tlac s exelu

jano5 • 12.6. 9:44

GRAF teploty

JoKe • 12.6. 9:22

Filtrování dat

Imh0tep • 12.6. 8:35