< návrat zpět

MS Excel


Téma: Počet výtisků.... rss

Zaslal/a 21.5.2009 13:01

Mám problém s výpočtem počtu výtisků a počtu dní měněných cardtridgí tiskáren. Např. z této tabulky:

kde typ je typ zda černá (B), žlutá (Y) atd...
a strany jsou celkové strany vytištěné na tiskárně , chtěl bych to prohledat smerěm nahoru a spočítat počty stran od poslední výměny ke konkrétní barvě náplně a počet dní , od poslední výměny. Čili by se hledalo např. B směrem nahoru další B a pak se odečetli jednotlivé hodnoty z rádků. Poradí někdo jak na to?

Příloha: jpg527_catch4.jpg (245kB, staženo 30x)
527_catch4.jpg
Zaslat odpověď >

icon #000528
admin
Použil jsem vyhledávací funkci SVYHLEDAT. Musel kvůli tomu prohodit sloupce tak, aby první sloupec by Typ.
Pokud vyhledávací funkce nic nenajde jedná se o první výměnu a Počet dní a Počet stránek = 0. Když tak si vzorec můžete ještě upravit. Řešení je v příloze.


=KDYŽ(JE.CHYBHODN(SVYHLEDAT(B11;$B$3:$C10;2;0));0;C11-SVYHLEDAT(B11;$B$3:$C10;2;0))
Příloha: zip528_pocet_dni.zip (306kB, staženo 29x)
citovat
#000529
avatar
Už jsem se zaradoval , jak skvěle elegantní , ale počítá to blbě , do přílohy jsem hodil ručně mnou vypočítané hodnoty , jak to vychází vám a jak mě , ale vám to neustále narůstá , což není pravda. Je to vidět u černé náplně , kde se to liší , já to hodil do listu 2 jak jsem to řešil já , je to sice funkční , nicméně takové neelegantní. pomůžete co s tím?
Příloha: zip529_pocet_dni.zip (13kB, staženo 29x)
citovat
#000530
Jeza.m
Dneska mi to už moc nemyslí, takže by to třeba šlo jednodušeji, ale zkusil jsem to přes databázové funkce. V přiloženém souboru jsem ponechal původní data a mnou doplněné vzorce jsou ve sloupcích J a K + jsem si přidal pomocné DB kritéria sloupce L-O řádky 1 a 2 - identifikace typu (pojmenované oblasti).

Snad to takto bude vyhovovat - snad je to i elegantnější než řešení přes pomocné tabulky na listu 2 :-).

S pozdravem
M@

PS: Teď ještě koukám, že kontrolu chyby pro počet stran jsem udělal jen v buňce J3 a neroztáhl jsem to až dolu, ale to už si můžeš opravit :-). Ona ta chyba kterou tam ošetřuji může nastat jen na prvním řádku a tam je to ošetřený :-), takže když to zůstane jak to je, tak se nic neděje.
Příloha: zip530_pocet_dni.zip (14kB, staženo 29x)
citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

export xls - konkrétní sloupce a pořadí

Alfan • 30.9. 15:11

open book

elninoslov • 30.9. 13:36

Podmíněné formátování - kopírování

elninoslov • 30.9. 13:30

export xls - konkrétní sloupce a pořadí

elninoslov • 30.9. 13:17

spustit makro změnou hodnoty v buňce a svyhledat

PavDD • 30.9. 10:10

Podmíněné formátování - kopírování

mikar • 30.9. 9:58

open book

PavDD • 30.9. 9:23