< návrat zpět

MS Excel


Téma: Zápis makra_porovnání tří sloupců rss

Zaslal/a 13.11.2022 8:35

Prosím o radu na zápis makra, který vyhodí ve sloupci A hodnotu 1, 2 nebo 3 na základě toho, zda najde nějaký číselný údaj v jiném sloupci. Tzn. ve sloupcích B, C a D může a nemusí být číslo.
Pokud je číslo jen v jednom ze tří sloupců, do sloupce A se zapíše 1.
Pokud je číslo ve dvou ze tří sloupců, do sloupce A se zapíše 2.
Pokud je číslo ve tří ze tří sloupců, do sloupce A se zapíše 3.
Údaje ve sloupcích musí mít "neomezený-rostoucí" počet řádků.
Moc děkuji. 1

Jméno
Kontrola
Text
  b i u s img code url hr   1 2 3 4 5 6 7 8 9 10

#053837
avatar
a nestačí vzorcem

=(--JE.ČISLO(B1))+(--JE.ČISLO(C1))+(--JE.ČISLO(D1))citovat
#053838
Lugr
@JoKe
teoreticky stačí toto:

=POČET(B1:D1)

ale on chce makro.

@Zumi
zkus to jednoduše takhle:


Dim wsDATA As Worksheet
Set wsDATA = Worksheets("List1")

SLB = wsDATA.Cells(Rows.Count, "B").End(xlUp).Row
SLC = wsDATA.Cells(Rows.Count, "C").End(xlUp).Row
SLD = wsDATA.Cells(Rows.Count, "D").End(xlUp).Row

RADEK = Application.WorksheetFunction.Max(SLB, SLC, SLD)

wsDATA.Range("A1").Resize(RADEK).Formula = "=IF(COUNT(B2:D2)=0,"""",COUNT(B2:D2))"
wsDATA.Range("A1").Resize(RADEK).Value = wsDATA.Range("A1").Resize(RADEK).Value
citovat
#053848
avatar

JoKe napsal/a:

a nestačí vzorcem

=(--JE.ČISLO(B1))+(--JE.ČISLO(C1))+(--JE.ČISLO(D1))


díky, také využiji 1citovat
#053849
avatar

Lugr napsal/a:

@JoKe
teoreticky stačí toto:

=POČET(B1:D1)

ale on chce makro.

@Zumi
zkus to jednoduše takhle:


Dim wsDATA As Worksheet
Set wsDATA = Worksheets("List1")

SLB = wsDATA.Cells(Rows.Count, "B").End(xlUp).Row
SLC = wsDATA.Cells(Rows.Count, "C").End(xlUp).Row
SLD = wsDATA.Cells(Rows.Count, "D").End(xlUp).Row

RADEK = Application.WorksheetFunction.Max(SLB, SLC, SLD)

wsDATA.Range("A1").Resize(RADEK).Formula = "=IF(COUNT(B2:D2)=0,"""",COUNT(B2:D2))"
wsDATA.Range("A1").Resize(RADEK).Value = wsDATA.Range("A1").Resize(RADEK).Value


MOC DÍKY 1citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

Hromadné přepsání

elninoslov • 24.5. 10:29

Hromadné přepsání

Nomi • 24.5. 8:32

Index - každý rok začít od 1 Power Query

Alfan • 23.5. 9:17

nepřímý odkaz

elninoslov • 23.5. 0:00

nepřímý odkaz

bordov • 22.5. 18:35

vrácené hodnoty

Anonym • 22.5. 15:46

vrácené hodnoty

Anonym • 22.5. 15:45