< návrat zpět

MS Excel


Téma: Když - IF rss

Zaslal/a 21.11.2023 13:59

AlfanDobrý den, nějak jsem se zacyklil.
Chci napsat podmínku KDYŽ.
A když je podmínka splněna, viz příloha, potřebuji, aby se vepsal vzorec z buňky A8 a provedl se výpočet.
V buňce A8, ale nemám vzorec s "=". Pokud by to šlo, potřeboval bych to mít v buňce A8 vždy bez toho "=".
Můžete mi, prosím někdo poradit?
Díky.
Radek

Příloha: zip55677_wall.zip (7kB, staženo 3x)
Zaslat odpověď >

Strana:  1 2   další »
#055678
elninoslov
Vytvorte si Definovaný názov napr. "PROVEST_VZOREC"
=EVALUATE("="&List1!$A$8)
=VYHODNOTIT("="&List1!$A$8)

a potom do C2 dajte
=IF(A2=2;PROVEST_VZOREC;4444)
=KDYŽ(A2=2;PROVEST_VZOREC;4444)
citovat
#055679
Alfan
Omlouvám se, ale chci se zeptat.
Pokud potřebuji například 4 vzorce, mohu je pojmenovat takto?

vzorec1 =EVALUATE("="&procedure!$D$5)
vzorec11 =EVALUATE("="&procedure!$D$6)

vzorec2 =EVALUATE("="&procedure!$D$8)
vzorec22 =EVALUATE("="&procedure!$D$9)

Ten list, kde ty vzorce jsou se jmenuje "procedure".

Mně to totiž nefunguje.
Radekcitovat
#055680
Stalker
Jestli máš CZ Excel tak místo EVALUATE použij VYHODNOTITcitovat
#055681
Alfan
Hodnota je
Mám tam tento vzorec:
=KDYŽ(procedure!$A$2=2;vzorec2;vzorec1)

a vypíše to toto:
VYHODNOTIT("="&procedure!$D$8)

Já nevím.citovat
#055682
elninoslov
Samozrejme, zabudol som na preklad :)

Skúste dať preč
"="&
vraj to má byť text bez "=", mne to fičí s ním aj bez neho.

EDIT:
Nechce sa mi to overovať, tak to prehodím na Vás. Overte ďalej, či EVALUATE/VYHODNOTIT pozná CZ vzorce.
A určite sa nevysomári mimo Tabuľky z tohto
[@trip]
Potom skúste iba jednoduchý vzorec, napr.
KDYŽ(1=1;1+2;5+5)
, žiadne TYP, JE.CHYBHODN, SVYHLEDAT a pod.citovat
#055683
Alfan
Omlouvám se, ale nerozumím co mám udělat?
Nechce sa mi to overovať, tak to prehodím na Vás. Overte ďalej, či EVALUATE/VYHODNOTIT pozná CZ vzorce.
A určite sa nevysomári mimo Tabuľky z tohto
[@trip]

Potom skúste iba jednoduchý vzorec, napr.
KDYŽ(1=1;1+2;5+5)

A co znamená toto? "nevysomári"
A určite sa nevysomári mimo Tabuľky z tohto
[@trip]
Jako, že nemohu použí odkaz na sloupec z Tabulky?
Děkuji.
Radekcitovat
#055684
elninoslov
nevysomári - nevyzná sa, neporozumie, je z toho somár 5

Nemôžete použiť
[@trip]
nezabúdajte, že je to textový reťazec, a on nevie o akú ide Tabuľku. Musíte použiť
tblPokus[@trip]

A to vyskúšanie jednoduchých vzorcov som myslel presne ako som napísal. Neskúšajte to VYHODNOTIT rozchodiť na polmetrovom vzorci využívajúcom pokročilé funkcie, ale na jednoduchom KDYŽ ako som napísal.citovat
#055685
Alfan
Tento vzorec mi funguje:
=KDYŽ(procedure!$A$2=1;1+1;2+2)

Jen nevím, jak mám ověřit ten vzorec.
Když jsem se pokusil zadat ve Správci názvů toto, tak mi to píše, že mám chybu ve vzorci:
=EVALUATE (4+4)
=EVALUATE (8)
=VYHODNOTIT (4+4)
=VYHODNOTIT (8)
a nešlo to zadatcitovat
#055686
avatar
Neměl by to být text?
=VYHODNOTIT ("4+4")citovat
#055688
elninoslov
Áno, už som to tiež písal vyššie. Parameter v EVALUATE/VYHODNOTIT je text.

@Alfan: nemôžete priložiť nejakú anonymizovanú prílohu? Lepšie by sme to dokázali implementovať na nej. Nech je vidno čo je Tabuľka, kde sú texty (vzorce), čo treba pridať (odkaz na Tabuľku/list do textu vzorca) ...citovat

Strana:  1 2   další »

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

Tlac s farebneho

ivana1 • 19.6. 22:16

GRAF teploty

Scraper • 18.6. 15:34

Vyhledat dnešní datum když je číslo jako text

veny • 17.6. 13:56

Vyhledat dnešní datum když je číslo jako text

Ontik • 17.6. 12:07

Zaokrouhlování

lubo • 17.6. 12:03

Zaokrouhlování

JoKe • 14.6. 15:19

Zaokrouhlování

Mirek-Kraus • 14.6. 13:52