< návrat zpět

MS Excel


Téma: vyhledat rss

Zaslal/a 11.1.2024 14:01

Zdravím.
Poradil by prosím někdo?
Změnou bunky C3, spustím makto ktere : vyhledá tuto hodnotu v zelené oblasti A24-A29 /bude pojmenovaná třeba ´oblast´ . Pokud najdeme výskyt napíše do A1 "JE TAM", jinak "NENALEZENO".
Díky za radu

Příloha: zip55918_najdi-v-oblasti.zip (14kB, staženo 3x)
Zaslat odpověď >

#055919
elninoslov
A k čomu makro??? Veď tam dajte iba vzorec
=IF(COUNTIF(oblast;C3)>0;"JE TAM";"NENALEZENO")
=KDYŽ(COUNTIF(oblast;C3)>0;"JE TAM";"NENALEZENO")


ak rozdelené makro tak:
Private Sub Worksheet_Change(ByVal Target As Range)
Dim KeyCells As Range

' Tato buňka nebo oblast když se změní, spouští se makro
Set KeyCells = Range("C3")

If Not Intersect(KeyCells, Target) Is Nothing Then
' Následující makro se změnou buňky nebo oblasti spouští
Over KeyCells.Value
End If
End Sub


Sub Over(ByRef hodnota_bunky As Variant) 'ověří jestli se hodnota buňky nachází v oblasti
' Debug.Print hodnota_bunky

Application.EnableEvents = False
Range("A6").Value = IIf(IsError(Application.Match(hodnota_bunky, Range("oblast"), 0)), "NENALEZENO", "JE TAM")
Application.EnableEvents = True
End Sub

ak spojené tak
Private Sub Worksheet_Change(ByVal Target As Range)
Dim KeyCells As Range

' Tato buňka nebo oblast když se změní, spouští se makro
Set KeyCells = Range("C3")

If Not Intersect(KeyCells, Target) Is Nothing Then
' Následující makro se změnou buňky nebo oblasti spouští
' Debug.Print hodnota_bunky

Application.EnableEvents = False
Range("A6").Value = IIf(IsError(Application.Match(KeyCells.Value, Range("oblast"), 0)), "NENALEZENO", "JE TAM")
Application.EnableEvents = True
End If
End Sub
citovat
#055920
avatar
A co třeba podmíněný formát v buňce C3? Vzorec: =COUNTIF(oblast;C3)>0citovat
#055923
avatar
Děkuji za řešení, vyberu nejvhodnější. Hezký dencitovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

rozpis zápasů hráčů pro utkání dvou týmů

Anonym • 25.5. 11:54

Hromadné přepsání

elninoslov • 24.5. 10:29

Hromadné přepsání

Nomi • 24.5. 8:32

Index - každý rok začít od 1 Power Query

Alfan • 23.5. 9:17

nepřímý odkaz

elninoslov • 23.5. 0:00

nepřímý odkaz

bordov • 22.5. 18:35

vrácené hodnoty

Anonym • 22.5. 15:46