< návrat zpět

MS Excel


Téma: nepřímý odkaz rss

Zaslal/a 22.5.2024 18:35

v excelu mám v buňce následující vzorec

=SVYHLEDAT(AD7;FIN_prij!AD$7:AL2000;8;NEPRAVDA) vše O.K

nedaří se mi přepsat vzorec tak, abych hodnotu 2000 zjistil
přes nepřímý.odkaz v buňce B1. Stále mi to hlásí chybu

=SVYHLEDAT(AD7;FIN_prij!AD$7:nepřímý.odkaz("AL"&B1);8;NEPRAVDA)
Může mi někdo poradit ? Díky moc.

Zaslat odpověď >

#056552
elninoslov
Skúste radšej INDEX
=VLOOKUP(AD7;FIN_prij!AD$7:INDEX(FIN_prij!AL:AL;$B$1);8;FALSE)
=SVYHLEDAT(AD7;FIN_prij!AD$7:INDEX(FIN_prij!AL:AL;$B$1);8;NEPRAVDA)

ale môžete aj INDIRECT/NEPŘÍMÝ.ODKAZ
=VLOOKUP(AD7;INDIRECT("FIN_prij!AD7:AL"&$B$1);8;FALSE)
=SVYHLEDAT(AD7;NEPŘÍMÝ.ODKAZ("FIN_prij!AD7:AL"&$B$1);8;NEPRAVDA)

rozdiel zbadáte, ak premenujete list FIN_prij.citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

Tlac s farebneho

ivana1 • 19.6. 22:16

GRAF teploty

Scraper • 18.6. 15:34

Vyhledat dnešní datum když je číslo jako text

veny • 17.6. 13:56

Vyhledat dnešní datum když je číslo jako text

Ontik • 17.6. 12:07

Zaokrouhlování

lubo • 17.6. 12:03

Zaokrouhlování

JoKe • 14.6. 15:19

Zaokrouhlování

Mirek-Kraus • 14.6. 13:52