< návrat zpět

MS Excel


Téma: Podmínění formátování rss

Zaslal/a 28.12.2014 23:21

Dobrý den!
Protože jsem začátečník 7 v excelu a potřeboval bych poradit,jak je v přiloženém souboru zajištěno barevné rozlišení každého dalšího řádku po zadaní textu do buňky ve sloupci A.Vím ,jak nastavit podmínku formátu každého sudého nebo líchého řádku,ale ne,v tomto případě.Jde to podmíněným formátem nebo snad i makrem?
Předem díky za radu.

Příloha: rar22915_cislovani.rar (11kB, staženo 20x)
Zaslat odpověď >

#022916
Hav-Ran
Nejde o podmienené formátovanie (to sa tam niekto pokúšal urobiť - viď pripojený obrázok) ale o vstavaný objekt Tabulka (pri aktivácii niektorej bunky sa objaví hore panel Nástroje tabuliek a TAM si vyberieš štýl zobrazovania a iné vlastosti.
Příloha: jpg22916_22915_podmformat.jpg (20kB, staženo 22x)
22916_22915_podmformat.jpg
citovat
#022917
avatar
Jenom pro úplnost, podmíněným formátováním by to šlo také. Styl tabulky ale bude v tomto případě lepší...
P.

Př. pro sudé řádky:
=KDYŽ(A(A1<>"";MOD(ŘÁDEK(A1);2)=0);PRAVDA;NEPRAVDA)citovat
#022918
avatar
Alebo
=A(A1<>"";ISEVEN(ŘÁDEK())
prípadne
=A(A1<>"";ISODD(ŘÁDEK())citovat
#022919
avatar

Pavlus napsal/a:

Jenom pro úplnost, podmíněným formátováním by to šlo také. Styl tabulky ale bude v tomto případě lepší...
P.

Př. pro sudé řádky:
=KDYŽ(A(A1<>"";MOD(ŘÁDEK(A1);2)=0);PRAVDA;NEPRAVDA)

To KDYŽ je tam zbytočné. Postačí
=A(A1<>"";MOD(ŘÁDEK(A1);2)=0)citovat
#022926
avatar
Díky za radu.Ale protože jsme lama,tak i když vzorec pro podmíněné formátování mám a je funkční,tak se mi vždy změní barva JEN jedné buňky ve sloupci A a ne celý řádek.Jak nastavit pro celý řádek v požadovaném rozsahu /např. A1-L1/?Požil jsme vzorec podmínyk formátování : =KDYŽ(A1:K20>0;MOD(ŘÁDEK();2)=0). Případně jak nastavit styl tabulky,aby se vždy změnil barevný formát každého druhého /lichého/ řádku až po vyplnění hodnoty v buňkách sloupce A?
Předem díky za radu
Příloha: rar22926_test1.rar (7kB, staženo 20x)
citovat
#022927
avatar
Upravený vzorec od Pavluse a rozšířený na více řádků a sloupců - stačí takhle?
Příloha: zip22927_cislovani.zip (12kB, staženo 20x)
citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

cislovanie riadkov

martin1 • 18.1. 20:47

Podmíněné formátování

Baja • 18.1. 18:55

VBA - načtení dat ze souboru s proměnným názvem

Fantasyk • 18.1. 14:29

zápis čísla fce suma

Stalker • 18.1. 13:17

smazání více obrázků

Zdenda-R • 18.1. 9:47

výpis adresáře

Milan-158 • 18.1. 9:31

zápis čísla fce suma

Josef-Sekan • 18.1. 9:26