< návrat zpět

MS Excel


Téma: Sčítání buněk z více listů dynamicky rss

Zaslal/a 22.1.2016 15:36

Dobrý den,
prosím o pomoc s tímto řešením. Sešit má 12 listů pojmenovaných "List_1" až "List_12". V každém je stejná tabulka. Potřebuji sestavit vzorec, který bude použit v tabulce každého listu a bude sčítat hodnoty buněk na adrese G20 ze všech listů v rozsahu List_1 až List_n. List_n je list ve kterém se nachází vzorec. Sestavil jsem tento vzorec, ale vrací chybu Odkaz!

Zaslat odpověď >

#029473
avatar
=SUMA(List1:List12!G20)

Vzorec nebere listy podle jména, ale podle pozice, tj sečte všechny listy mezi List1 a List12, včetně uvedených.citovat
#029475
Opičák
nebo tak

edit: tento vzorec BERE listy podle jména
Příloha: zip29475_soucet-stejnych-bunek-z-vice-listu.zip (11kB, staženo 210x)
citovat
icon #029479
avatar
chlapci, mám za to, že pavelo chce na liste2 vzorec
=SUMA(List1:List2!G20)
na liste 3 potom =SUMA(List1:List3!G20) atd.

ale chce to vzorcom, ktorý bude mať na každom liste rovnaký tvar

pokiaľ to tak je, tak to žiada istú predprípravu, svoj pokus o riešenie dávam v prílohe.

Alebo makrom..
Příloha: zip29479_pom.zip (7kB, staženo 66x)
citovat
#029485
avatar
A nemůže být pouze chyba v zadání: "Sešit má 12 listů pojmenovaných "List_1" až "List_2". Nemá tam být ... až List_12"? Pak sečtu jen List_1!G20+List_2!G20 ... do List_n. Vzorec pak lze snadno rozkopírovat do okolních buněk tabulky. S vloženou přílohou při zadávání by to bylo určitě jednodušší.
Příloha: zip29485_scitani12.zip (9kB, staženo 42x)
citovat
#029486
avatar
Moji představu správně pochopil AL. Ano, v zadání jsem měl chybu, v první větě má být: "...12 listů pojmenovaných List_1 až List_12." (už opraveno)
Chtěl jsem vyjít ze vzorce, jak uvádí lubo. Nefunguje to ale s nepřímým odkazem - sestavil jsem následující vzorec, který se mi v prvním příspěvku nepodařilo vložit:
SUMA(NEPŘÍMÝ.ODKAZ("List1:"&ČÁST(POLÍČKO("filename";G20);NAJÍT("]";POLÍČKO("filename"))+1;31)&"!G20")) Vrací ale chybu #REF!, u verze Excel 2016 potom #ODKAZ!citovat
icon #029488
avatar
Nepriamy odkaz nefunguje v kombinácii s 3D.citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

VBA - načtení dat ze souboru s proměnným názvem

€Ł мσşqμΐτσ • 22.1. 19:28

Sumar nakupov

Pavlus • 22.1. 13:05

VBA - načtení dat ze souboru s proměnným názvem

Fantasyk • 22.1. 9:12

Sumar nakupov

Robo11 • 21.1. 21:23

VBA - načtení dat ze souboru s proměnným názvem

€Ł мσşqμΐτσ • 21.1. 12:21

Tělo emailu ve VBA - formát

Fantasyk • 20.1. 20:47

odstranenie opakujucich sa udajov v riadkoch

frantilopa • 20.1. 18:12