< návrat zpět

MS Excel


Téma: Funkce KDYŽ rss

Zaslal/a 27.3.2017 11:59

Zdravim,

potreboval bych pomoci se spravnym pouzitim vzorce KDYZ. Vzorec mam nastaveny takto =KDYŽ(L2=5;E2-D2;D2-E2). Jednoduse potrebuji udelat rozdil dvou bunek s podmínkou, ze pokud bude v bunce č.5 tak bude rozdil E2-D2 a pokud bude č.6 pripadne jiné číslo prohodi rozdil na D2-E2.

Zaslat odpověď >

Strana:  1 2   další »
#035784
elninoslov
A čo Vám na tom nefunguje ? Veď to máte tak, ako potrebujete, nie ?citovat
#035786
avatar
Pocita pouze E2-D2. Nebere v potaz pokud bude jiné cislo nez 5 a nepouzije vypocet D2-E2.citovat
#035788
avatar
Si si istý, že v bunke L2 je iné číslo? Alebo D2 je rovnaké ako E2.
Daj tvoju adresu, možno sa niekto na to u teba pozrie. 2citovat
#035789
avatar
Jsem si jistý protože ve sloupci L mam 5 a 6 ucty (nakladove, vynosove) a potrebuji rozdil MD-D (5) přip. D-MD (6)citovat
#035790
avatar
Tak potom asi máš iný excel, ako my ostatní. 4citovat
#035791
avatar
Posílám příklad...
Příloha: xlsx35791_sesit1.xlsx (11kB, staženo 34x)
citovat
icon #035793
eLCHa
Problém je, že vy nemáte ve sloupci K číslo 5, ale text "5" (funkce ZLEVA vrací text). A to není to samé, proto vám to počítá stále jako <>5.
Když už to máte takto - převeďte to na číslo=ZLEVA(A4;1)/1nebo upravte=KDYŽ(K4="5";D4-C4;C4-D4)citovat
#035795
avatar
Děkuji za radu. Ale mám pořád stejný problém. U 6xxxxx počítá stálé špatný rozdíl viz příloha :-(
Příloha: xlsx35795_sesit1.xlsx (11kB, staženo 37x)
citovat
icon #035796
eLCHa
Počítá správně.
-1532749,72
Máte to zobrazeno v tisících.
-1533
Nastavte obecný formát, případně odstraňte vlastní formát.citovat
#035797
Jeza.m
Tipuji, že problém bude v "5", pokud už máte zformátováno jako číslo, tak by tam měla být čistě 5.citovat

Strana:  1 2   další »

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

Excel - zápatí

masox22 • 28.2. 10:55

Současné rozplánování více projektů v Excelu -4

exceleda • 28.2. 10:04

Současné rozplánování více projektů v Excelu -4

elninoslov • 27.2. 22:52

konsolidace II.

pmiki • 27.2. 20:58

Současné rozplánování více projektů v Excelu -4

exceleda • 27.2. 18:36

Současné rozplánování více projektů v Excelu -4

elninoslov • 27.2. 14:30

Soubor bez přípony

elninoslov • 27.2. 14:26