< návrat zpět

MS Excel


Téma: Vyhledání nejbližšího nižšího data rss

Zaslal/a 7.3.2023 15:20

Vážení,
potřebuji vyhledat nejbližší nižší datum, které je přiřazeno k určitému textu. SVYHLEDAT mi na toto samozřejmě nefunguje.
Sloupce A a B jsou vstupní data. Ve sloupci C chci výsledek. Sloupce E a F jsou "databáze" údajů, ze kterých má být hledáno.
Pro toto zatání se má vyhledat 1. 1. 2023.
Prosím existuje nějaká funkce, která by byla vhodná?
Díky.

Příloha: xlsx54583_vyhledat_datum.xlsx (9kB, staženo 4x)
Zaslat odpověď >

#054586
avatar
Umím to jen s pomocným sloupcem. V pomocném sloupci je rozdíl mezi zadaným datumem a prohledávánými datumy. Hledá se minimální kladné číslo.
Jedná se o maticový vzorec, který se ukončuje Ctrl+shift+Enter

=INDEX(F2:G6;POZVYHLEDAT(MIN(KDYŽ(G:G>=0;G:G));G2:G6;0);1) P.S. Nemá se vyhledat 1.1.2023, ale 1.2.2023
Příloha: xlsx54586_54583_vyhledat_datum.xlsx (13kB, staženo 3x)
citovat
#054587
elninoslov
Pre Excel 2019, 2021, 365:
=MAXIFS(F2:F6;F2:F6;"<"&A2;E2:E6;B2)
pre Excel 2010+
=AGGREGATE(14;4;(F2:F6<A2)*(E2:E6=B2)*F2:F6;1)
inak maticový vzorec
=LARGE(IF((F2:F6<A2)*(E2:E6=B2);F2:F6;FALSE);1)
=LARGE(KDYŽ((F2:F6<A2)*(E2:E6=B2);F2:F6;NEPRAVDA);1)
citovat
#054588
avatar

elninoslov napsal/a:

Pre Excel 2019, 2021, 365:
=MAXIFS(F2:F6;F2:F6;"<"&A2;E2:E6;B2)

Díky. Kdybych asi si budu muset někde sehnat jen seznam funkcí excelu.citovat
#054589
avatar
Možností je docela dost:

=MAX((E2:E6=B2) * (F2:F6<=A2) * (F2:F6))
=MAX(FILTER(F2:F6;(E2:E6=B2)*(F2:F6<=A2)))
=VYHLEDAT(A2;SORT(FILTER(F2:F6;E2:E6=B2)))
=SVYHLEDAT(A2;SORT(FILTER(F2:F6;E2:E6=B2));1)citovat

Uživatelské menu

Nejste přihlášen(a)
avatar\n

Menu

On-line nástroje

Formulář Faktura

Formulář Faktura IV

Oblíbený formulář Faktura byl vylepšen a rozšířen.
Více se dočtete zde.

Aktivní diskuse

Hromadné přepsání

elninoslov • 24.5. 10:29

Hromadné přepsání

Nomi • 24.5. 8:32

Index - každý rok začít od 1 Power Query

Alfan • 23.5. 9:17

nepřímý odkaz

elninoslov • 23.5. 0:00

nepřímý odkaz

bordov • 22.5. 18:35

vrácené hodnoty

Anonym • 22.5. 15:46

vrácené hodnoty

Anonym • 22.5. 15:45